Commit 89ad59a8 authored by gsell's avatar gsell
Browse files

deprecated function em.install_doc() replaced

parent c2f6dcf4
......@@ -34,15 +34,10 @@ function em.install() {
make -C tools install
}
function em.install_doc() {
install -m 0444 \
AUTHORS \
COPYING \
"${DOCDIR}"
}
em.add_to_family 'HDF5'
em.set_runtime_dependencies "${COMPILER}" "${MPI}" 'hdf5'
em.set_build_dependencies "autoconf" "automake" "libtool" "${COMPILER}" "${MPI}" "vtk" "hdf5"
em.set_docfiles 'AUTHORS' 'COPYING'
em.make_all
......@@ -39,11 +39,9 @@ function em.install() {
install -m 0444 "${MODULE_SRCDIR}"/SRC/*.h "${PREFIX}/include"
}
function em.install_doc() {
install -m 0444 README "${DOCDIR}"
}
em.add_to_family 'MPI'
em.set_runtime_dependencies "${COMPILER}" "${MPI}"
em.set_build_dependencies "${COMPILER}" "${MPI}" "OpenBLAS"
em.set_docfiles 'README'
em.make_all
......@@ -37,10 +37,6 @@ function em.install() {
make PREFIX="${PREFIX}" install
}
function em.install_doc() {
:
}
em.add_to_family 'Compiler'
em.set_runtime_dependencies "${COMPILER}" 'OpenBLAS'
em.set_build_dependencies "${COMPILER}" 'OpenBLAS'
......
......@@ -43,10 +43,6 @@ function em.install() {
:
}
function em.install_doc() {
:
}
em.add_to_family 'Compiler'
em.set_runtime_dependencies "${COMPILER}"
em.set_build_dependencies "${COMPILER}"
......
......@@ -43,19 +43,11 @@ function em.install() {
:
}
function em.install_doc() {
install -m 0444 \
CHANGES \
INSTALL \
LICENSE.txt \
README \
VERSION \
"${DOCDIR}"
}
em.add_to_family 'MPI'
em.set_runtime_dependencies "${COMPILER}" "${MPI}"
em.set_build_dependencies "${COMPILER}" "${MPI}"
em.set_docfiles 'CHANGES' 'INSTALL' 'LICENSE.txt' 'README' 'VERSION'
em.make_all
em.cleanup_src
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment