...
 
Commits (2)
...@@ -13,8 +13,10 @@ Now configure jupyter ...@@ -13,8 +13,10 @@ Now configure jupyter
## Package notes ## Package notes
- cudatoolkit version is fixed because it needs to match merlin6's CUDA module - cudatoolkit version should ideally match merlin6's CUDA module
(required by the MotionCor2 package). (required by the MotionCor2 package). However, tensorflow needs cuda 10.0 while
- This environment installs packages for gpu support, but these currently don't no MotionCor2 binary is available. For now, having a different version in
seem to be working on merlin. conda and modules is working OK, but it could cause problems with future compilation.
- You can test GPU support by running this command on a GPU machine:
`python -c 'import tensorflow as tf; print(tf.test.is_gpu_available())'`
...@@ -4,30 +4,23 @@ channels: ...@@ -4,30 +4,23 @@ channels:
- defaults - defaults
dependencies: dependencies:
- python=3.7 - python=3.7
- dask # Explicit cryocare dependencies from singularity
- dask-jobqueue - tensorflow-gpu=1.15.0
- deap
- docopt
- graphviz
- ipython
- ipywidgets
- keras - keras
- matplotlib - tifffile
- mrcfile - mrcfile
- nb_conda_kernels
- numpy # Other dev packages
- jupyter
- dask
- dask-jobqueue
- pandas - pandas
- plotly
- pytables
- python-graphviz
- scikit-learn - scikit-learn
- scipy - scipy
- seaborn - seaborn
- tensorflow=1.13.1 - plotly
- tensorflow-gpu - pytables
- tifffile - pip
- cudatoolkit=9.2
- cudnn
- pip: - pip:
- csbdeep - csbdeep
- pixiedust - pixiedust