Commit 0e8e4e9e authored by feichtinger's avatar feichtinger

Merge branch '65-update-anaconda-envs-for-xlrd-jupytext-conda-build' into 'master'

Resolve "update anaconda envs for xlrd, jupytext, conda-build"

Closes #65

See merge request Pmodules/buildblocks!79
parents 81381c98 03cc1e64
...@@ -5,6 +5,7 @@ channels: ...@@ -5,6 +5,7 @@ channels:
dependencies: dependencies:
- python=3.6 - python=3.6
- pandas - pandas
- xlrd
- numpy - numpy
- scipy - scipy
- scikit-learn - scikit-learn
...@@ -17,6 +18,8 @@ dependencies: ...@@ -17,6 +18,8 @@ dependencies:
- deap - deap
- nb_conda_kernels - nb_conda_kernels
- ipywidgets - ipywidgets
- plotly
- python-graphviz
# Note that the dask 2.1.0 with python 3.6 led to a non-functioning configuration # Note that the dask 2.1.0 with python 3.6 led to a non-functioning configuration
# (serialization errors in dask). Therefore we exclude it here. # (serialization errors in dask). Therefore we exclude it here.
# - dask # - dask
...@@ -5,6 +5,7 @@ channels: ...@@ -5,6 +5,7 @@ channels:
dependencies: dependencies:
- python=3.7 - python=3.7
- pandas - pandas
- xlrd
- numpy - numpy
- scipy - scipy
- scikit-learn - scikit-learn
...@@ -18,5 +19,9 @@ dependencies: ...@@ -18,5 +19,9 @@ dependencies:
- deap - deap
- nb_conda_kernels - nb_conda_kernels
- ipywidgets - ipywidgets
- plotly
- dask - dask
- dask-jobqueue - dask-jobqueue
- python-graphviz
- bayesian-optimization
...@@ -6,4 +6,5 @@ channels: ...@@ -6,4 +6,5 @@ channels:
dependencies: dependencies:
- python=3.6 - python=3.6
- ldapuserdir - ldapuserdir
- cython # for pyslurm
- conda-build
...@@ -9,3 +9,4 @@ dependencies: ...@@ -9,3 +9,4 @@ dependencies:
- jupyter_contrib_nbextensions - jupyter_contrib_nbextensions
- ipywidgets - ipywidgets
- pip - pip
- jupytext
...@@ -4,6 +4,7 @@ channels: ...@@ -4,6 +4,7 @@ channels:
dependencies: dependencies:
- python=3.6 - python=3.6
- pandas - pandas
- xlrd
- numpy - numpy
- scipy - scipy
- scikit-learn - scikit-learn
......
...@@ -5,6 +5,7 @@ channels: ...@@ -5,6 +5,7 @@ channels:
dependencies: dependencies:
- python=3.6 - python=3.6
- pandas - pandas
- xlrd
- numpy - numpy
- scipy - scipy
- scikit-learn - scikit-learn
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment