Commit 98daea70 authored by bliven_s's avatar bliven_s
Browse files

Add new MotionCor2 variants

Also standardize the MotionCor2 wrapper so that it's the same for all
module versions regardless of cuda support
parent 58881d81
......@@ -6,6 +6,7 @@
4. Move all executables to /opt/psi/EM/MotionCor2/$VERSION/bin
5. Move user manual to /opt/psi/EM/MotionCor2/$VERSION/
6. Fix permissions: chmod 755 /opt/psi/EM/MotionCor2/$VERSION/bin
7. Create bin/MotionCor2 wrapper for each version
## Cuda versions
......
#!/bin/bash
# Script directory. Better than $MOTIONCOR2_HOME/bin since it can be called without loading modules.
BIN="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null 2>&1 && pwd )"
if [ -z ${CUDA_VERSION} ]; then
echo 'MotionCor2 requires the cuda module. Run `module load cuda/<version>`' >&2
exit 1
fi
CUDA=$(echo "${CUDA_VERSION}" | sed -r 's/([0-9]+)\.([0-9]+)(\..*)/\1\2/')
EXE=$(echo "$BIN"/MotionCor2_*_Cuda${CUDA}*)
#echo "Running $EXE"
if [ ! -x "$EXE" ]; then
echo "MotionCor2/$MOTIONCOR2_VERSION is not compatible with cuda/$CUDA_VERSION" >&2
exit 1
fi
exec "$EXE" "$@"
......@@ -18,5 +18,6 @@ pbuild::compile() {
pbuild::install() {
cp $BUILDBLOCK_DIR/files/LICENSE $PREFIX/
cp -r $BUILDBLOCK_DIR/bin $PREFIX/
}
......@@ -8,3 +8,6 @@ MotionCor2/1.3.0 stable
MotionCor2/1.3.1 stable
MotionCor2/1.3.2 stable
MotionCor2/1.4.0 stable
MotionCor2/1.4.5 stable
MotionCor2/1.4.7 unstable
MotionCor2/1.5.0 unstable
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment